donderdag 25 januari 2018

Twittercards

Een twittercard is een automagische preview van een link in een tweet.
Bij mijn blogs verscheen die preview niet. Ik had al eens bij Blogger gezocht hoe ik dat in kon stellen maar die optie is er niet. Dus ik deed er tot op heden handmatig een plaatje bij. En nieuwe artikelen worden via Zapier getwitterd mèt plaatje. Bij Wordpress schijnt er wel een plugin voor te zijn.

Toch wilde deze code-blinde beelddenker graag twittercards hebben. Na wat trial&error-gedoe met deze instructies voor developers bleek het reuze-simpel.
Kwestie van een stukje code plakken in je html en bij twitter de ingestelde card valideren.


Ga naar thema -> html bewerken en daar plak je dit stukje code direct onder <head>

<meta name="twitter:card" content="summary" />

Vervolgens test en valideer je de twittercard hier.
Klaar!

Let op; als je net zoals ik een framekiller hebt ingesteld crasht Blogger als je naar thema gaat. Kijk hier hoe je toch bij html bewerken kunt komen.

Met twittercards is veel meer mogelijk. Tonen van een grote foto, een andere achtergrondkleur, een andere titel, een vast logo als foto. Kijk voor alle opties hier.
De automagische preview verschilt per apparaat. Op je mobiel staat de intro er bijvoorbeeld niet bij.

Mijn webwinkel bleek al een twittercard te hebben. Alleen pakt ie daar het plaatje niet bij de card validator -> doorgegeven aan support. Ook bij de verschillende blogs doet de twittercard niet altijd wat ie moet doen. Blogger heeft helaas geen support die antwoord geeft....

Tot slot mijn volgers nog even lastig gevallen met wat getest. Soms deed de card het niet, soms heeft de card even tijd nodig voor ie verschijnt.

Intro klopt niet. Hij toont de beschrijving van het blog zelf, niet van het artikel. Dit was bij de validator ook.

Gaat goed!

De eerste die ik probeerde werd niet getoond. De validator liet de goede titel van het artikel zien. Maar hier zie ik de titel van het blog...

Gaat goed!

Gaat goed!

Intro ontbreekt. Was bij de validator ook zo.

Tot slot de webwinkel. Nu toont ie wel een plaatje, in de validator niet.

Voorlopig weer genoeg geknutseld. Alleen nog even de plaatjes uitzetten bij Zapier.
Maar als iemand nog weet hoe de foutjes eruit te krijgen?